Page 1 of 1

Linux Clients not finding executable

PostPosted: 08 Aug 2016, 18:51
by Rob
Hi, I'm trying to set up a render farm with linux clients, but I'm having no success...

Under renderer management -> executables -> Operating system: Windows I set Search paths (64 bit) to C:\Program Files\path-to-renderer\renderer.exe and it works fine.
If I go to Operating system: Linux and set it to /path-to-renderer/renderer it fails with the log showing:

Result: Erroneous
Error: No executable specified for the renderer

If I copy the path from RenderPal and paste it into a terminal it works fine (as a user or as root).

Any suggestions?

Re: Linux Clients not finding executable

PostPosted: 09 Aug 2016, 10:03
by Shoran Support
Have you tried setting the executable using the remote client configuration? The error does not tell you that the executable cannot be found, but that none is configured at all (we'll look into this to see if it is a bug in the Linux client).

Re: Linux Clients not finding executable

PostPosted: 09 Aug 2016, 11:20
by Rob
I was trying to set the executable via the Remote Controller, is there another / better way?

Thank you, just let me know if you would like logs configuration details etc.

Re: Linux Clients not finding executable

PostPosted: 09 Aug 2016, 11:24
by Shoran Support
You have set the executable in the renderer management, where you can only set "fallback" executables; use the Remote Client Configuration to properly configure your clients.

Re: Linux Clients not finding executable

PostPosted: 09 Aug 2016, 11:40
by Rob
Perfect thank you!