clients not reporting chunk finished

If you are seeking for help, this is the right place to ask!

Re: clients not reporting chunk finished

Postby madCGi » 04 Mar 2016, 12:29

though we currently use max 2016 and vray 3.3 we have seen this issue using 2015 and older versions of vray. but we have been having more issues recently.
madCGi
 
Posts: 42
Joined: 14 Nov 2014, 11:41

Re: clients not reporting chunk finished

Postby ch3m1kal » 04 Mar 2016, 14:37

No domain right now, that's actually planned shortly and I'm curious if it will fix the issue in any way.
RenderPal runs as an app, since it's too complicated to handle permissions for services right now.
ch3m1kal
 
Posts: 26
Joined: 23 Feb 2015, 13:09

Re: clients not reporting chunk finished

Postby madCGi » 04 Mar 2016, 14:43

ch3m1kal wrote:No domain right now, that's actually planned shortly and I'm curious if it will fix the issue in any way.
RenderPal runs as an app, since it's too complicated to handle permissions for services right now.


well that helps me rule out whether our domain permissions are to blame and that running as an application or service makes no difference.

seems to me like its has to be one of the following:
1. problem with 3ds max > personally i think this is unlikely.
2. problem with RenderPal > though the problem is with RenderPal not registering completed jobs, i dont believe there is anything that should cause this issue.
3. temporary loss of connectivity due to server traffic/load > i feel like this is probally the cause of the problem, but it is very hard to diagnose and prevent.

whatever is causing this issue it could be solved if RenderPal checks periodically if there is a difference / discrepency between the clients event log and the job the server believes it is running.
madCGi
 
Posts: 42
Joined: 14 Nov 2014, 11:41

Re: clients not reporting chunk finished

Postby madCGi » 04 Mar 2016, 14:52

dont know if this has anything to do with it, but what anti-virus/security and firewalls are you running?

fyi: we use symantec.
madCGi
 
Posts: 42
Joined: 14 Nov 2014, 11:41

Re: clients not reporting chunk finished

Postby ch3m1kal » 04 Mar 2016, 16:15

Already ruled security software out.

Dedicated render slaves are separate from artist machines and they have the same issue even though they run no additional security and even the windows firewalls are disabled.
I think the server failing to acknowledge a finished chunk event is most likely, since the render slaves just sit there, with no current job showing up in the client and remotely disconnecting the stuck client causes the last rendered chunk to restart.
That might also explain why sometimes, though very rarely, I see chunk restart events "while machine was offline" even though the machine was operating properly the whole time.

I'm thinking of maybe trying to migrate the RenderPal server to a Linux environment and see if somehow that fixes anything, since currently that's running on Windows too.
Last edited by ch3m1kal on 04 Mar 2016, 16:23, edited 1 time in total.
ch3m1kal
 
Posts: 26
Joined: 23 Feb 2015, 13:09

Re: clients not reporting chunk finished

Postby madCGi » 04 Mar 2016, 16:19

That is exactly the same problem we have been having with exactly the same symptoms. If RenderPal could somehow check for this that would fix it. Until that happens to properly diagnose it I guess I have to........ Purposely overload the server!?? :p
madCGi
 
Posts: 42
Joined: 14 Nov 2014, 11:41

Re: clients not reporting chunk finished

Postby Shoran Support » 04 Mar 2016, 19:46

I also believe that the only fix is a period client check; added to our to do list.
User avatar
Shoran Support
RenderPal Team
 
Posts: 1166
Joined: 11 Apr 2008, 00:35
Location: Germany

Re: clients not reporting chunk finished

Postby madCGi » 07 Mar 2016, 14:40

Shoran Support wrote:I also believe that the only fix is a period client check; added to our to do list.


good to hear. i will post more if i find another workaround or solution, but hopefully this can be implemented and rolled out quickly.
madCGi
 
Posts: 42
Joined: 14 Nov 2014, 11:41

Re: clients not reporting chunk finished

Postby ch3m1kal » 08 Mar 2016, 08:57

Shoran Support wrote:I also believe that the only fix is a period client check; added to our to do list.


Maybe add a server acknowledge event after a client reports chunk finished, and if the client does not receive that it retries every x seconds?
Assuming it doesn't already work that way, of course, I haven't actually had time to analyze RenderPal's network traffic.
ch3m1kal
 
Posts: 26
Joined: 23 Feb 2015, 13:09

Re: clients not reporting chunk finished

Postby ch3m1kal » 25 Apr 2016, 17:12

Hey, I've actually managed to catch one of the stuck clients with verbose message log enabled.

See if it helps in any way.
You do not have the required permissions to view the files attached to this post.
ch3m1kal
 
Posts: 26
Joined: 23 Feb 2015, 13:09

PreviousNext

Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron